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CHAPTER 1 - INTRODUCTION

The Tank Monitor Software is used for the SeeLeveL 900D6 with  
902 & 903 options to:

MODBUS/SERIAL

OR

1. Record Data

The Tank Monitor Software 
obtains and stores data 
from the SeeLeveL 900D6  
either  wirelessly or with a 
hardwired Modbus 232/ 
485/422 serial connection.

The data transmitted & recorded includes status, level, volume, 
temperature, fluid interface volume & level, communication 
type, and display type.

2. View Data

Once stored, the constantly 
updating data can be viewed 
in a chart, historically or by 
monthly average.

3. Publish Data

The stored data can be sent 
off and published as a print 
or an automated e-mail.

The purpose of this manual is to ensure your tank monitoring 
system runs correctly. Before the installation and setup of the 
software, this manual will first give preliminary requirements for 
the software. Software functions and uses will also be covered. 
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CHAPTER 2 - PRELIMINARY REQUIREMENTS

To effectively use the software, ensure that:

1. Compatable GARNET hardware has been successfully installed.

Ensure that your current hardware setup is correct using the 
table below. Please see the separate product manuals for 
specific product installation instructions. 

*Or follow the proceedures outlined in the following pages. 

2. Install Required Device Driver

A device driver on a computer is a program that controls 
hardware attached to that computer. The included hardware 
for your chosen communication method requires a proper 
driver to integrate with the computer. Please see the table 
above for where to obtain the proper driver for your setup. 

Communication 

Method

Compatible 

Display

Required 

Option

Computer 

Hardware

Required

Driver

Wireless 900D6S

900D6D

900D6Q

900D6I

902 952 USB XSC Obtained from Garnet 

website, under Software 

Downloads*

Modbus (Hard-

wired)

900D6S

900D6D

900D6Q

900D6I

900D4 

903 953 USB 485 Obtained from Garnet 

website, under Software 

Downloads*
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This chapter will show how to obtain, and then install the proper 
driver for your setup. 

CHAPTER 3 - DRIVER INSTALLATION

http://ftp1.digi.com/support/driver/Digi_USB_RF_Drivers.exe

OR
Find it on the web:

1. Go to www.digi.com

2. Go to Support>Drivers

Obtaining Wireless USB Driver
(see page 7 for obtaining Modbus USB driver)

Either enter the link into your 
address bar on your web 
browser:

3. Select XBee-PRO XSC RF Modules from the list

Direct Entry Method: 



Page 6 902-903 Manual

4. Select Drivers Installer for Windows to start the download.

5. Save or Run the 
download as desired. 
See page 8 for 
help with the driver 
installation.
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Obtaining Modbus USB Driver

Modbus USB Driver: Direct Entry

Either enter the link into 
your address bar on your 
web browser:
http://www.bb-elec.com/getattachment/c8461811-bebf-456a-
8386-6ea1281219b4/USB_Drivers_PKG_v2-08-28.zip.aspx

OR
Find it on the web:

1. Go to www.bb-elec.com
2. Search: USOPTL4-LS, and select the product.

3. Select Documentation/Downloads in the product menu.

4. Download and install the Software/Drivers/Firmware for the 
USOPTL4-LS: (See page 8 for help with the driver installation)
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Installing the driver

1. A window will prompt you 
to Save, Run, or Cancel the 
opening of the driver.
 
Select Run, or Save then 
Run, based on your web 
browser.

2. Follow on-screen 
instructions, then select 
Next.

3. Select installation 
location, then select 
Install.

4. Wait until setup is complete, 
then select Next.

   NOTE: The images shown are of the Wireless driver installation
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5. Select Finish.

It is recommended to 
reboot the computer after 
installation is finished.

NOTE: Windows Security may 
show this window. 
Select Install if it appears.

a. For Wireless Communication: 

Plug in the Garnet Instruments Tank Monitor 
952-USB XSC box to a USB socket on the 
computer. 

OR

b. For Modbus (Hardlined) Communication: 

Plug in the wired USB adapter to a USB 
socket on the computer.

7. A message should show in 
the bottom right corner.

6. 

It is recommended to reboot 
the computer after installation 
is finished.                            
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The software is found on the Garnet Instruments website:
http://www.garnetinstruments.com/

Once the link has been selected:

CHAPTER 4 - SOFTWARE INSTALLATION

Double-click

1. A window will prompt you 
to Save, Run, or Cancel the 
opening of the software 
file.
 
Select Run, or Save then 
Run, based on your web 
browser.

2. Select to Open the 
downloaded file, and 
double-click the enclosed 
application.

3. Follow instructions on 
the window, then select  
Next. 

4. Read the license agreement, 
then check the “I Agree” box, 
and select  Next.
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5. Enter your name and 
company then select  Next.

6. Select Typical Setup. 
  
For Remote or Simple 
Installation, select Custom. 
See pg. 13 for information on Typical, 
Remote, and Simple Installation 
options. 
 
Select Next.

7. If Custom was selected, 
select desired items for 
installation, then select Next.

8. Select your install location 
then select  Next.
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9. Enter the preferred 
Program Group and which 
computer users to include 
on the installation then 
select  Next.

It is recommended to 
reboot the computer after 
installation is finished.
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CHAPTER 5 -  INITIAL SOFTWARE SETUP

Software Overview

Trend Chart - This chart will show the daily measurement trend 
for the selected  tank.

Tank List - This area shows the monitored tanks that are con-
nected to the software, and their current properties.

Toolbar Overview
1. File - for printing of Tank List and selected Trend Chart
2. Edit - To delete/insert tanks from/into the Tank List
3. View* - manage which tank properties are visible in the Tank 

List, as well as viewing Historical & Monthly Reports
4. Setup - for initiating the communication type, and any e-mail 

report generation. Also allows for detailed data**
5. Help - shows software version and launches manual

Toolbar Trend Chart

Tank List

After opening the software, the program should appear as follows: 

*for more information on different ways to view data, see the View Data section on page 19.

**Detailed Data is a tool used for troubleshooting only.   
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The diagram above is a simplified view of the functioning of 
the Tank Monitoring Software. A more accurate and technical 
description of how the program functions is shown below: 

MODBUS/SERIAL
OR

How It Works
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MODBUS

OR

port 6000
localhost 

Software
(aka “Client”)

port 6000

IP address of LOCAL computer
within LAN

LOCAL COMPUTER

REMOTE COMPUTER

-Garnet Service running when computer is on.
-Client App talks to Garnet Service to get data.

Connection to Garnet Service on Local 
Computer is required.
-Note that Remote computers only
 monitor live data, they will NOT be
 able to view any historic data; only the
 Local Computer can do this.

MODBUS

OR DIRECT COM PORT

-The Garnet Service not installed or turned off.
-Uses Serial Port from the Application.
-Data only records when the Client App is running.

 
The decision is left to the customer which installation method 
best suits the specific application.

Software
(aka “Client”)

Software
(aka “Client”)
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2. Go to Client tab.

For Typical or Remote 
Installation methods, select 
Use Windows Service. 
 
For the Simple Installation 
method, select Use Serial 
Port from the Application. 
Ensure that the Garnet Service 
is not installed or turned off. 
 
See Appendix C for more details on managing the 

Garnet Service

Initial Setup - Comm Setup

1. Go to Setup>Comm Setup.

3. For Typical Installations enter: 
“localhost” for the IP Address, 
and “6000” for the TCP/IP Port       (recommended) 
 
For Remote Installations enter: 
the IP Address of the Local Computer, and a chosen TCP/IP 
Port. 
Contact your network administrator if you do not know the 
IP address of the Local Computer.

We’ll now go through the inital setup for the Tank Monitor Software. 
Start by making sure the tank monitors can communicate properly 
with the software by going through Comm Setup. 
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4. Under the Service tab 
enter your TCP/IP port. 
A port number 6000 is 
recommended.

6. Ensure:
Baud Rate is 9600
Parity is None
Data Bits is 8
Stop Bits is 1
Debug is 0

5. Select the Serial Port 
used for the monitor 
communication.*

7. Ensure that Status reads 
Service Running. Select 
Start Service if Service is 
not running.

Select Apply.

* see Appendix A to see which COM port is being used by connected devices

NOTE: If the software is not connecting to the hardware, 
please check for software running in the background that 
could be using the COM port. 
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Initial Setup - Managing Tanks

2. Enter the Tank ID of the 
tank you want to add to 
the Tank List.

The Tank ID must be 
the same valid Tank ID 
set in the display of the 
monitored tank you 
are wanting to add: 

Adding a Tank

3. Name the tank  under Tank Name. This can be customized to 
whatever is best for your application.

4. Enter in the Communication method used to connect the 
monitor to the computer.

Select OK

The tank will show up in the Tank List. 
 

Deleting a Tank

To delete a tank, select it in the Tank List and go Edit>Delete Tank

1. Go Edit>Insert Tank

Communication Mode Valid Tank ID
Wireless 0-9999
Modbus 1-255

 
Note: to view SeeLeveL 900D6 gauge tank ID go to the 
Short User Code (SUC) menu and Press ↑↑ FAST UP to 
access the Tank ID menus
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Now that we’ve added a tank to the Tank List it’s time to go over 
how the software stores the data it obtains from the monitor, 
different ways you can view this data, and how you can share this 
data.

CHAPTER 6 - STORING, VIEWING, AND PUBLISHING DATA

MODBUS

OR

SERIAL

OR

Data Storage

In order for data to 
be stored onto the 
computer there are 
two requirements:

1. The communication method (wireless, modbus, or serial) must 
be functioning and 

2. For Typical Installations: Garnet Service is active  
For Simple Intallations: Garnet Service is not active, instead 
it’s using the Serial Port from the Application

In Typical Installations Garnet Service runs in the background 
of any computer that the Tank Monitor Software is installed 
on, even if the Tank Monitor Software isn’t opened up.

* See Appendix C for Managing the Garnet Service
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Viewing Data

1. Historical Report

Shows the data obtained 
for the selected day. To 
access the historical report
Go View>Historical 
Report...

The date, tank, and data 
shown can all be changed.
To:
change Date select the Date drop-down 

arrow
change Tank select the Tank drop down 

arrow
change Data Shown select the Columns button
Print the Report select the Print button

Once stored, the constantly updating data can be viewed in a 
chart, historically, or by monthly average via the Tank Monitor 
Software on the local computer.
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To:
change the Date select the Date drop-down arrow
change the Tank select the Tank drop down arrow
change Data Shown select View and select/deselect 

the data types

Data Types:
a) Level - Fluid level
b) Volume - Fluid volume
c) Temp - Fluid temperature
d) Level Above & Below - For 900D6I: indicates fluid  
 level above and below the interface
e) Vol Above & Below - For 900D6I: indicates fluid       
 volume above and below the interface
f) Alarms 1, 2, 3 & 4 - indicates the alarm statuses of  
 all alarm points, if applicable
g) Battery Display - indicates the battery status of the  
 display
h) Battery Sender - indicates the battery status of the  
 sender bar
i) Com Type - Communication Method of the selected  
 tank
j) Display Type - Display model that is monitoring the  
 selected tank

Data Shown

Tank Selection

2. Chart View

Shows the data obtained for the selected day in chart form.

Date
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Printing the Chart View:

To print the Chart Trend 
Go File > Print Trend... 
 
 
 

This will bring up the Print 
Preview window for the 
Chart Trend.

Desired printing properties 
can be selected and the 
chart can then be printed.
 

3. Monthly Report

Shows the monthly average 
for the tank. To access the 
monthly report

Go View>Monthly Report

The date, tank, and data shown can all be changed.

change the Date Select the Date drop-down arrow.  
The average will be calculated 
based on the month of the selected 
date.

change the Tank Select the Tank drop down arrow
change Data Shown Select the Columns button
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Publish Data

2. Enter the email address you wish to send the email from. 

To setup an email schedules and recipients:

Note: the DataType “On Alarm 
Changes” will send an email when  
an alarm point is hit or changed on 
Garnet monitoring equipment.

The data can be publish by printing it, as described in the previ-
ous section, or by e-mail.

E-mail Setup
To initially setup the email system go to Setup>Email Setup...

1. Check with your Internet Service Provider to obtain the SMTP 
Host and Port used by the email software on the computer.

3. Enter the email address of 
the recipient & DataType: 
the schedule for sending 
the data. DataType choic-
es are shown to the right. 

4. Select Apply

1. Go to Email Schedule 

2. Select Add
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APPENDIX A - COM PORT SETUP

After installing the proper drivers on the computer and connecting 
the computer with Garnet hardware it may be necessary to check 
the COM port the Garnet hardware is using on the computer.

1. Click on the windows 
start button and type 
“device manager” into 
the seach bar. 
 
Select Device Manager 
 

2. Under “Ports” you can 
see the COM ports 
currently used on the 
computer. 
 
In the window it shows: 
 
“Digi USB Serial Port” 
is using COM3 on the 
computer, the driver for 
the Wireless Device 
 
AND 
 
“RS-485 Port” is using 
COM4 on the computer, 
the driver for the mod-
bus device.
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Available options for Serial-based communication methods 
are shown below:

RS232
SERIAL

Under Comm Setup Select the Use 
Serial Port from the Application 
intead of Using Windows Service.

Simple Serial Method (RS232)

Daisy Chained Serial Method (RS485 or RS422)

RS485
RS422

APPENDIX B - MODBUS SERIAL SETUP

Software
(aka “Client”)

Software
(aka “Client”)
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APPENDIX C - GARNET SERVICE

MODBUS
OR

SERIAL
OR

port 6000

local host 

LOCAL COMPUTER

The user may desire to start and stop Garnet Service from receiving 
data or “transmitting” to the Client/Software.

1. Click on the Windows 
Start button and type 
“services” into the 
search window. 
 
Select Services 
 

To turn “on” Garnet Service:

To find Garnet Service click on 
the start button, type “services” 
and click on the “Services” 
program.

Garnet Service should appear in the Services window:

This section will show how to find Garnet Service once 
it has been successfully installed on the computer. 

Software
(aka “Client”)
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2. Find Garnet Service in 
the window, 
 
Right click on it and 
select Properties 

3. Under “General”, 
select Startup type as 
Automatic 
 
Then select Start under 
“Service status” 
Select OK.
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To Turn “off” the Garnet Service:

3. Under “General”, 
select Startup type as 
Manual. 
 
Then select Stop under 
“Service status” 
Select OK. 

1. Click on the Windows 
Start button and type 
“services” into the search 
window. 
 
Select Services

2. Find Garnet Service in the 
window, 
 
Right click on it and se-
lect Properties. 
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APPENDIX D - SERVICE AND WARRANTY INFORMATION

DISCLAIMER OF WARRANTY ON SOFTWARE
You expressly acknowledge and agree that use of the Software is at your sole risk. The Software and 
related documentation are provided “AS IS” and without warranty of any kind and Garnet Instruments 
Ltd. expressly disclaims all warranties, express and implied, including, but not limited to, the implied 
warranties of merchantability and fi tness for a particular purpose. Garnet Instruments Ltd. does 
not warrant that the features contained in the software will meet your requirements, or that the 
operation of the software will be uninterrupted or error-free, or that defects in the software will 
be corrected. The entire risk as to the results and performance of the software is assumed by you. 
Furthermore, Garnet Instruments Ltd. does not warrant or make any representations regarding the 
use or the results of the use of the Software or related documentation in terms of their correctness, 
accuracy, reliability, currentness, or otherwise. No oral or written information or advice given 
by Garnet Instruments Ltd. or Garnet Instruments Ltd.’s authorized representative shall create a 
warranty or in any way increase the scope of this warranty. Should the software prove defective, you 
(and not Garnet Instruments Ltd. or Garnet Instruments Ltd.’s authorized representative) assumes 
the entire cost of all necessary servicing, repair or correction. Some jurisdictions do not allow the 
exclusion of implied warranties, so the above exclusion may not apply to you.

LIMITATION ON WARRANTIES
Under no circumstances including negligence, shall Garnet Instruments Ltd., or its directors, offi cers, 
employees or agents, be liable to You for any incidental, indirect special or consequential damages 
(including damages for loss of business profi ts, business interruption, loss of business information, 
and the like) arising out of the use, misuse or inability to use the software or related documentation, 
breach or default including those arising from infringement or alleged infringement of any patent 
trademark, copyright or other intellectual property right by Garnet Instruments Ltd., even if Garnet 
Instruments Ltd. or Garnet Instruments Ltd.’s authorized representative has been advised of the 
possibility of such damages. Some jurisdictions do not allow the limitation or exclusion of liability 
for incidental or consequential damages, so the above limitation or exclusion may not apply to 
you. Garnet Instruments Ltd. will not be liable for 1) loss of or damage to your records or data or 2) 
any damages claimed by you based on any third party claim. In no event shall Garnet Instruments 
Ltd.’s total liability to you for all damages, losses, and causes of action (whether in contract, tort--
including negligence--or otherwise) exceed the amount paid by you for the Software.

If you do have a warranty claim or if the equipment needs to be serviced, contact the installation 
dealer.  If you do need to contact Garnet, we can be reached as follows:

CANADA UNITED STATES
Garnet Instruments Ltd. Garnet US Inc.
286 Kaska Road 5360 Granbury Road
Sherwood Park, AB  T8A 4G7 Granbury, TX  76049
CANADA   USA
email:  info@garnetinstruments.com email:  infous@garnetinstruments.com
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